PHPUnit 3.6をインストールする

notoです。

UnitTestFrameWork PHPunitのインストール方法の備忘録です。

PHPUnit 3.6のインストール

PHPUnit 3.6の推奨環境

  • PHP 5.3.8 以降
  • Xdebug 2.1.2 以降

php-pear、xdebugはインストールされているものとします。 PHPUnitをインストールするためにphp-xmlパッケージが必要なので、インストールされているか確認します。

1
$ rpm -q php-xml

インストールされていない場合は、インストールを行います。

1
$ yum install php-xml

PHPUnit3.6のインストール

以下の2つのコマンドを実行します。

1
2
$ pear config-set auto_discover 1
$ pear install pear.phpunit.de/PHPUnit

インストール終了後、phpunitコマンドを実行し確認を行います。

1
$ phpunit -v

Comments